Close

User Tag List

Results 1 to 11 of 11

Thread: odometer issue

  1. #1
    tbagsaturn's Avatar
    Join Date
    Mar 2012
    Location
    Southern California
    Posts
    257
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    odometer issue

    My car has always had this problem where the odometer is easily visible during the day (3rd gen digital), but when I turn my headlights on at night, it disappears.. but when I got my subframe from the junkyard and had it put in, something they did made it work at night, and now it doesn't again.. its not like its faded and super hard to read, its just not there.

    Any help?

  2. #2
    crazy98saturn's Avatar
    Join Date
    Aug 2011
    Posts
    640
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Does the rest of your dash lights work? I know I had a problem similar to it, but my lights did not work and ended up being my dimmer switch. I would not let any lights on or the digital part work. Mine is a 99.


    I dsm's

  3. #3
    tbagsaturn's Avatar
    Join Date
    Mar 2012
    Location
    Southern California
    Posts
    257
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Every other light works in the car no problem.

  4. #4
    6S Moderator S.Bretz's Avatar
    Join Date
    Apr 2004
    Location
    Lutz, Fl
    Posts
    15,121
    Post Thanks / Like
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    SOunds like the little bulb in the cluster is bad.

    I don't think the subframe/cradle repair had anything to do with it working. I would be it was just a coincidence.
    -6S Resident Mechanical Forensics member #001.
    1995 SC2 Turbo 3.6L DOHC, 6sp manual, Ford 8.8 rearend running on MS3x.
    1998 F-250 5.4L triton...stock.

  5. #5
    tbagsaturn's Avatar
    Join Date
    Mar 2012
    Location
    Southern California
    Posts
    257
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    its just weird because it didnt work for the first year and a half...then the accident, then it works for 6 days and now it doesnt :/ and why would i be able to see it during the day, but when i flip the headlights on it doesnt?

    would a cluster swap give me accurate miles of my car or the donor car?

  6. #6
    dynonacht's Avatar
    Join Date
    Jul 2012
    Location
    farmington mn
    Posts
    3,069
    Post Thanks / Like
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    3rd gen store miles in bcm so whatever cluster you get will show accurate mileage
    2001 red Sc2m R.I.P.
    1998 gold Sc2m (Goldylocks) Ms2 turbo construction
    1995 white Sc1.5m N/A (Becky) R.I.P.
    1999 navy blue Outback 2.5m (un named) DD

  7. #7
    HNIC SC2Sick's Avatar
    Join Date
    Nov 2004
    Location
    St. Paul, Minnesota
    Posts
    11,067
    Post Thanks / Like
    Blog Entries
    4
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    One of the perks is that you can swap to a better looking cluster.
    Sixthsphere.com Owner
    2016 Honda Fit
    2003 BMW e46
    2001 Saturn SC2 - Forged with everything but boost - FOR SALE PM FOR MORE INFO
    1998 Ford Ranger

  8. #8
    Administrator PurdueGuy's Avatar
    Join Date
    Jan 2006
    Posts
    7,799
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Sounds like a flaky backlight issue. Seems like it may be an LED in the 3rd gen clusters? Not sure.
    SaturnSeries.net Owner
    '99 SC2 Project Car build thread

  9. #9
    tbagsaturn's Avatar
    Join Date
    Mar 2012
    Location
    Southern California
    Posts
    257
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it is an led, but its just weird that it works fine when just the running lights are on...guess il have to cluster swap.

  10. #10
    6S Moderator S.Bretz's Avatar
    Join Date
    Apr 2004
    Location
    Lutz, Fl
    Posts
    15,121
    Post Thanks / Like
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    They don't use LED's. They are normal bulbs...just really tiny normal bulbs. It work some times because the filament re-contacts and temporarily welds back together.
    -6S Resident Mechanical Forensics member #001.
    1995 SC2 Turbo 3.6L DOHC, 6sp manual, Ford 8.8 rearend running on MS3x.
    1998 F-250 5.4L triton...stock.

  11. #11

    Join Date
    Mar 2014
    Location
    The hills of eastern PA
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    S. Bretz - Thanks for the information. My odometer ( 1999 SC2 ) just started acting up at night. ie: I wouldn't show then I would wack the dash and it worked again. I was fearing some sort of weird odometer replacement process was in my future but if it's just little tiny bulbs I'll take care of that the next time I have the dash apart. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •