Close

User Tag List

Results 1 to 20 of 20
  1. #1
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Roof rack thread (sticky?)

    I think we need a definitive roof rack thread. The info is here and around, but needs to be consolidated.

    All my info has been scrounged from here and friends or members.

    The available setups:
    (Work in progress, * = optional)

    Please copy/paste to keep info useable
    Body Style:
    Rack brand:
    Rack towers:
    Feet:
    Clips:
    Cross bars*:
    Notes*:
    It's not my fault, blame the radiation.

  2. #2
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Body Style: 2nd gen SL
    Rack brand: Yakima
    Rack towers: Q-towers
    Feet: (see clips)
    Clips: F-Q67 / R-Q68
    Cross bars*:
    Notes*:

    Screen shotted from Yakima fitment site:


    I've had trouble with my Yakima Q tower setup on my 2nd gen SL from day 1. I'm pretty positive my (used) clips are bent, but can't find enough definitive info or pictures to be sure. For years now, I've set it up in the only way I can that gets tension on the feet and secures the rack to the car. But the clips move and I don't like it.

    I will re-set it up as specified by Yakima above and report back.
    Last edited by ZombieSatty; 05-11-2017 at 11:33 AM.
    It's not my fault, blame the radiation.

  3. #3
    HNIC SC2Sick's Avatar
    Join Date
    Nov 2004
    Location
    St. Paul, Minnesota
    Posts
    11,048
    Post Thanks / Like
    Blog Entries
    4
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Roof rack related question:

    2001 SC2 with sunroof with the sunroof bubble up front.. Can I still run a roof rack with that? I'd like to be able to put one of those storage racks up there for road trips or something
    Sixthsphere.com Owner
    2016 Honda Fit
    2003 BMW e46
    2001 Saturn SC2 - Forged with everything but boost - FOR SALE PM FOR MORE INFO
    1998 Ford Ranger

  4. #4
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Typically yes you can on a SL. However, on a coupe, I'm not sure if it can clear when open, would clear the bubble/deflector/fairing I'm pretty sure. Someone will have to verify.

    Sent from my SM-G930P using Tapatalk
    It's not my fault, blame the radiation.

  5. #5
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Here's a photo of the Yakima clips (and rack with Thule bike and cargo box attachments) for comparison. It's installed on a 2001 Sedan using Yakima's measurements. My 99 SL2 has a sunroof with the deflector option, if it comes down to it I can move it over and see what the clearance is.

    North Bay-20130429-00778.jpg

    North Bay-20130429-00779.jpg

    North Bay-20130429-00777.jpg

    SmallIMG_20150328_105706.jpg
    Last edited by trottida; 05-11-2017 at 12:10 PM.
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  6. #6
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Here's a photo of the OEM racks. I believe they were manufactured by Saris but I could be wrong.

    Saturn Racks2.JPG

    Saturn Racks.JPG
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  7. #7
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Yeah, my clips must be bent. They dont fit like that.

    Yes, I think Saris made all the racks for Saturn. The Lseries one I bought/ sold years back looked identical.

    Sent from my SM-G930P using Tapatalk
    It's not my fault, blame the radiation.

  8. #8
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Here's a tip. Once you get your rack installed to the measured location take a sharpie and mark the location of the clips just under the rubber door seal. Once you've done this, when you remove and have to re-install you can be sure that it is in the right spot without having to re-measure.
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  9. Likes ZombieSatty, SC2Sick liked this post
  10. #9
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Good idea. I think the clips come with black sticker pads to do that as well. When bought new of course.

    Sent from my SM-G930P using Tapatalk
    It's not my fault, blame the radiation.

  11. #10
    Get off my lawn.
    Join Date
    Oct 2006
    Location
    Winston Salem, NC
    Posts
    8,254
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    I have this setup (not my car)



    There is no strap going over the door edge trim like the Yakima, it goes under it instead.

    Unfortunately, I'm not sure what towers I have or anything like that as its all out of production now

  12. Likes ZombieSatty liked this post
  13. #11
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ZombieSatty View Post
    Good idea. I think the clips come with black sticker pads to do that as well. When bought new of course.

    Sent from my SM-G930P using Tapatalk
    Those adhesive Teflon stickers actually get applied to the q-clip rather than the car. You test fit the q-clip to the car and observe where there is metal to metal contact and you position the pads on the the q-clip at those contact points. It basically wraps over the ends of the clips.
    Last edited by trottida; 05-11-2017 at 04:13 PM.
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  14. Likes ZombieSatty liked this post
  15. #12

    Join Date
    Jun 2009
    Location
    Hammond , Louisiana
    Posts
    1,352
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Do want...

  16. #13
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    After setting the rack up per the image I posted, I still can not get it secure. Especially without cranking it down so much that it distorts the rain gutter/ A-C pillar covers. I can't get the locks engaged either. Not sure what I'm doing wrong. I had one clip come lose while driving, with bikes up there no less, luckily I didn't bust a back window. And another time the front clips both slipped back a foot on the roof, but stayed latched. Maybe incorrect preload on my adjustment screws?

    I think I'm going to just say screw it and get some of thoes Landing Pad things and mount them permanently to the roof. It's an old car, I just need a safe and secure rack to transport the bikes.

    Sent from my SM-G930P using Tapatalk
    Last edited by ZombieSatty; 05-15-2017 at 01:37 PM.
    It's not my fault, blame the radiation.

  17. #14
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Are you sure you have the 67/68 q clips and you have them in the right positions - 67 on the front and 68 on the back? The clip number should be stamped on the clips if I recall. Maybe they sent you the wrong clips perhaps. Post up a photo of how they look on your car similar to what I posted. Did you try bending them so they look the same as my clips?

    I can't imagine them slipping back on the roof that much. I run them with 3 bike attachments all summer and occasionally with a 22 cubic foot cargo box. I've never had them move and I'm not cranking them down to the point the roof starts buckling. The only part of the clip that touches is covered by the door when closed. It shouldn't touch the top of that trim piece at all.
    Last edited by trottida; 05-15-2017 at 02:09 PM.
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  18. #15
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Yup, I took them apart this weekend and verified the clips and positions.

    I'll post pics tonight.

    Sent from my SM-G930P using Tapatalk
    It's not my fault, blame the radiation.

  19. #16
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    You can see in the pics how it's pulling on the pillar trim.

    Can you do me a favor and measure from the end of your cross bars to the tower? Do it from the top. I don't trust mine since it moved and it's a bitch to get accurate from the underside with the bike carriers installed.
    It's not my fault, blame the radiation.

  20. #17
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Just eye balling your Q towers and I think they are too far out (or twisted;left tower further forward than right). When you compare to my photo you see there is a good 1/4 inch plus gap from the tower pad to the inner edge of trim. I'll try to get a measurement tomorrow from load bar end to outer edge of the Q tower but the measurement in the diagram is inner edge to inner edge of both Q towers. The front bar measurement is 34 7/8 and the rear bar is 33 5/8.

    _qtower.JPG
    Last edited by trottida; 05-15-2017 at 09:30 PM.
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  21. #18
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    I saw the same thing. Before, clamping, mine look like yours. I did tighten them more after the rack came lose, that's why they are pulling more on the trim.

    Sent from my SM-G930P using Tapatalk
    It's not my fault, blame the radiation.

  22. #19
    trottida's Avatar
    Join Date
    Aug 2014
    Location
    Northern Ontario, Canada
    Posts
    153
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Alright, dark as dark can be outside but I threw on a headlamp and measured. Too dark for photos though. Mine are set at 4 7/16 for the front on both sides and 5 3/16 for the rear on both sides. That was measured with caps on.
    Current
    1999 SL2 MT (236K km, 10-2016 to present)
    2001 SL1 MT (400K km, 10-2008 to present)

    Past
    1993 SW2 AT (03-2000 to 04-2010)
    2001 LW200 MT (06-2001 to 01-2005)
    1992 SL2 MT (06-1992 to 09-1997)

  23. Likes ZombieSatty liked this post
  24. #20
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,268
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Thank you very much.

    I won't have time tomorrow to mess with it. Will report back soon.

    Sent from my SM-G930P using Tapatalk
    It's not my fault, blame the radiation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •