Close

User Tag List

Results 1 to 4 of 4
  1. #1
    silver01sw2's Avatar
    Join Date
    Sep 2015
    Location
    Michigan
    Posts
    159
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    HVAC Control cables...

    Does anyone know of an aftermarket source for them? The cable that operates the the mode control function has been bent so many times on mine that it finally snapped. And, on the heels of that, Any thoughts on what wears out on the blend air door in the mode control that makes it so damn hard to change and causes the cable to bend?

  2. #2
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,441
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    An intresting topic, not sure what to tell you besides pull some from junkyard. The mechanisms should move freely, if they are bending the rods. it'd maybe see if you can clean or lube the stuff further.
    It's not my fault, blame the radiation.

  3. #3
    silver01sw2's Avatar
    Join Date
    Sep 2015
    Location
    Michigan
    Posts
    159
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yeah, I figured I'd hit a yard or two today or tomorrow. I'm sure the blend air door is just worn, it does have about 325,000 on it now. It will move smoothly, except for when it reaches the extent of it's travel, that's where it likes to bind. Thought I had it beat last year, when I pulled the cable, and let the silicone soak down its length. Worked great for a few months, then when I need defrost one morning a week or so back, it started acting up again. I guess the only way to really take care of it, would be to pull the blend air box from under the dash. Not really my first choice, though.

  4. #4
    Approved Vendor ZombieSatty's Avatar
    Join Date
    Feb 2007
    Location
    Omaha, NE
    Posts
    6,441
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    I agree, the cables themselves probably aren't the real issue.
    It's not my fault, blame the radiation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •