Close

User Tag List

Results 1 to 3 of 3
  1. #1

    Join Date
    Feb 2019
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Saturn from the Devil

    I'm hoping someone can help me out.I bought a 1993 sc 1.9 liter 5 speed 2 months ago. 120,000 miles on her. Drove her home 40 miles no problems, ran awesome . 2 days later dead battery. Replaced alternator all was good. Couple days later she was hard to start, going down the road she would "buck" so hard, i almost hit my head on the steering wheel. Now all she wants to do is start, rev to 2000 and shut off. If you play with the throttle and let the clutch out it will "lurch" or "Buck" so hard you think the car would fall apart. Here are the new parts I have replaced
    1). fuel pump.
    2). fuel filter
    3). crank position sensor
    4). air idle control valve
    5). erg valve
    6). ngk plugs
    7). plug wires
    . 2 coil packs
    9).Had the ignition control module tested @ Auto Zone
    10). Throttle position sensor
    11). ECTS "brass tip"

    She has no check engine light on and no codes have been found
    Can someone please help me?
    Thank you very much

  2. #2
    6S Resident Hasselhoff. alexofnazareth's Avatar
    Join Date
    Nov 2010
    Location
    Columbus, IN
    Posts
    5,195
    Post Thanks / Like
    Blog Entries
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Check for any vacuum leaks? That would explain the revving while sitting still.
    Quote Originally Posted by Donnie View Post
    I see a failboat, steaming full speed on an ocean of failsauce into a barrier reef of lol.
    Quote Originally Posted by BC. Livewire View Post
    if you hate seeing money going down the drane

    than do not turbo your car !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    -----------------------------------------------------------------------------------------------------

    Sixthsphere: Home of newbs, cunts, and Shane Jackson.

  3. #3
    Resident Electromotive Expert importsdontlikeme's Avatar
    Join Date
    Feb 2010
    Location
    Westminster, Maryland
    Posts
    3,297
    Post Thanks / Like
    Blog Entries
    3
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    MAP sensor?


    Sent from my iPhone using Tapatalk Pro

    Interested in a solid engine management system? Ask me about Electromotive engine management.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •